Email Problems in Thunderbird

Hi. I am having a problem with email program Thunderbird. When I open Thunderbird on a morning I can see my email address but no in-box, sent items etc. i check the settings all seems ok. when I try to send it Say’s sent items is full delete some to make space (cannot see sent items) and it will not send or collect . I can close and reopen Thunderbird and reboot the laptop. It all makes no difference. Then when I try to set up the email again it all comes back and everything is there, in-box, out box etc and all the emails.
Is this a Thunderbird problem or an Ubuntu problem. Can anyone help me sort it please.
I am using Ubuntu 11.10 alongside windows xp.

Not sure if it’ll help, but try seeing if there is any problems with your harddrive. Run this in terminal:

sudo touch /forcefsck

And then restart your laptop. This will force fsck to check for problems with the HDD.
At least we’ll be able to eliminate if it’s the HDD. If it says anything try write it down, or take a video/picture.

Is there not a “Sent” folder in the All Folders view down the left hand side?

Is this an IMAP or POP3 account ?

It is a pop3 mail account with demon internet, all I have is the All Folders and my email address it’s all the other folders that are missing inbox out sent junk etc.
How do I open a terminal to run the fsck?

Ctrl+Alt+T (at the same time) will open a terminal … then enter

sudo touch /forcefsck

(hit enter and your password when asked)

then REBOOT … fsck will automatically be run at bootup before the partitions are mounted.

WARNING - DO NOT run fsck manually from the terminal … you can damage the file system if you run it on mounted partitions … run it as suggested above.

Hi. i have tried the fsck and rebooted. No errors found email just the same. I want to get it sorted so I can bin windows. Got any more idea’s what it may be?? ??? Getting frustrated with it.

in the left hand panel … underneath All Folders … is there a little arrow next to your email address ?

if so, what happens when you click that little arrow (or double-click your email address) ?

There is no arrow when the folders are not visable. At 21.00 hrs tonight everything came back dont know what I did if I did anything. I can only see the the arrow when the folders are there, I can click the arrow and the folder’s disappear and then again they come back. But when I cannot get the folder’s there is no arrow.
Mark

I wonder if it’s not displaying them because it’s still in the middle of trying to download your mail … though it should still display them ???

If it does it again … can you go to Edit > Account Settings > Server Settings and take a screenshot.

[EDIT]

I wonder what would happen if you compacted the folders -

File > Compact Folders

and can you post the exact (word for word) warning when it mentions that the “Sent” folder if full.

taken a screen shoot.
it should be attached, you can also see that the folders are missing

I’m going to take a guess here that your local mail folder is on a separate drive that isn’t mounted when you open Thunderbird ?

as it says that it is (or should be) mounted in /media

Is that drive mounted ? … is it set to automount in fstab, or do you have to manually mount it by accessing the drive through the nautilus file manager first ?

You’ll know it’s mounted if it has a little arrow next to it in the left hand panel of the Nautilus file manager.

My guess would be that you have to access it first to mount it … THEN (and only then) will it be available for Thunderbird.

Ideally your mail folder would be in your home directory, but if you need it on another drive/partition it may be best to mount it automatically at bootup through fstab.

or at the very least, access the drive once (to mount it) BEFORE opening Thunderbird.

It may also be worth checking that the drive is always assigned the same name (mount point) in /media

Sorted, ;D you make it sound so obvious. So how do I make it mount automatically and make it have the same mount point?

Is the drive always attached ? … or do you regularly plug/unplug the drive whilst the system is running ?

With the drive attached and mounted, what is the output from:

sudo fdisk -l

and

sudo blkid

and

mount

It is one hhd split partitioned in to C and D drives. Is it done from a terminal window? Do i just type in what you have put and then press enter between each one?
Mark

Ahh … if it’s a partition on an internal drive all the better … no need to worry about hot plugging :slight_smile:

Is this a dual-boot system (ie. Windows and Ubuntu ?

and is Linux installed “properly” (to a Linux formatted partition) or was it installed through WUBI ? … ie. In Windows is there a C:\ubuntu folder ?

Do i just type in what you have put and then press enter between each one?

Exactly :slight_smile:

Just open a terminal (Ctrl+Alt+T), enter the single command, then hit enter … commands that start with sudo may ask for your password, enter it and hit enter again.

Be Aware - When entering your password into a terminal, nothing will be echoed to screen (not even ******) but it is going in, just enter it and hit enter.

It may be better to copy/paste the commands into the terminal so you don’t mistype … for example, that’s an L at the end of the first command not a 1

and remember Linux commands (unlike Windows) ARE case sensitive … so it’s an l not an L :slight_smile:

Hi. yes dual boot windows XP and Ubuntu that was installed through WUBI. I have just looked and there is C/Ubuntu. Do I still follow the above to make it mount automaticaly?
At the moment I want to find out what works and how, what of programs I need to get and make sure my plotter etc all work ok. Then windows is history.
It started when I decided I was going to buy a new laptop, then I found out I would have to also buy office software, cad and pay for the upgrades for other software as well. So it’s good bye windows, just as soon as I dare. I just have a lot of learning to do with Linux.

Hmm … WUBI … a couple of things to be aware of …

  1. with a WUBI install you will NOT be able to fully get rid of Windows, as Ubuntu was installed “inside” the Windows file system … so don’t spend forever getting Ubuntu “just right”, only to discover that removing Windows will also remove Ubuntu … a WUBI install is fine for test driving, but if you decide to stick with Linux, a proper installation to a Linux partition is MUCH better.

  2. From what I gather WUBI installs cannot be dynamically resized, so you rae stuck with th hard drive space you originally allocated.

  3. If a WUBI install goes wrong … it CANNOT (AFAIK) be accessed from a LiveCD to be fixed.

To tell the truth, I’m not 100% sure how the mounting of the (rest of) the Windows partition works under WUBI, but if you send the output from the commands listed here:
http://linuxforums.org.uk/index.php?topic=9757.msg69808#msg69808
I should be able to advise how to automount the Windows partition(s) :slight_smile:

I am going to stop at this point. I know I have to access the d drive before entering email so as it is just test driving Ubuntu befor buying a new laptop I will live with it. I can still get the emails that’s what matters at the mo. Thanks for all the help. I will no dought have another question soon.
I am moving on to the plotter next, here’s been hopefull.
thanks
Mark :wink:

No problem … and you’re welcome :slight_smile: