No printer in tuxpaint (SOLVED)

For some reason I cant get my Grand-Daughters printer to work with tux paint, it works in other applications such as gedit, but when she tries to print directly from tux paint she just get an error message “cannot print”, I have the tux paint config tool and it’s set to allow printing, I’ve tried reasearching the problem online but can’t find a solution, another odd thing which may or may not be connected is that I can’t log into the cups interface, it wont accept username & password, So I’m not sure if this could be some kind of permissions problem, I have 2 users on that PC “family” & “chloe” and I can’t log in with either of them, I also looked into the etc/tuxpaint/tuxpaint.config file to see if I could find the problem there, but every setting is commented out with a # so it doesn’t look like it’s reading from that file but I’m probably misunderstanding that.

Any advice or help would be much appreciated

Many thanks

Graeme

What’s the output (in your daughters account) from:

groups

and

lpstat -p

[EDIT]

Try installing cups-bsd:

sudo apt-get install cups-bsd

Now try printing from tuxpaint.

chloe@Linux2 ~ $ groups
chloe adm cdrom sudo dip plugdev lpadmin lightdm nopasswdlogin sambashare
chloe@Linux2 ~ $ lpstat -p
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-l7cH6m/pkcs11: No such file or directory
printer Brother-MFC-210C is idle.  enabled since Thu 04 Apr 2013 06:42:42 BST
printer [email protected] is idle.  enabled since Thu 04 Apr 2013 07:43:38 BST
printer EPSON-Stylus-Photo-R200 now printing EPSON-Stylus-Photo-R200-0.  enabled since Thu 04 Apr 2013 07:43:39 BST
printer Samsung-CLP-320-Series is idle.  enabled since Thu 04 Apr 2013 07:43:40 BST
chloe@Linux2 ~ $ 

I tried installing cups-bsd as you suggested and it still wont print in tux paint, and cups will not accept username & password

Graeme

I also looked into the etc/tuxpaint/tuxpaint.config file to see if I could find the problem there, but every setting is commented out with a # so it doesn't look like it's reading from that file
Have you tried to look in "~/.tuxpaintrc" like this:
cat ~/.tuxpaintrc

As I understand this overrides etc/tuxpaint/tuxpaint.config

You might want to look at printcommand=COMMAND
as described here

Hi SeZo

Thanks for your input

chloe@Linux2 ~ $ cat ~/.tuxpaintrc
# Generated by tuxpaint-config version 0.0.12
windowsize=1400x960
altprint=always
startblank=yes
chloe@Linux2 ~ $ 
You might want to look at printcommand=COMMAND as described here

I had already looked at that page and done what you’ve suggested in the above quote but it still doesn’t work

Many thanks

Graeme

Something tells me we need to fix CUPS first … instaling cups-bsde worked for me in tuxpaint, nothing else was necessary.

Something tells me we need to fix CUPS first .. instaling cups-bsde worked for me in tuxpaint, nothing else was necessary.

That sounds like a cunning plan :slight_smile:

Which printer are you trying to print to … and is it set as the default printer in:-

menu>System Tools>Printing

?

Which printer are you trying to print to .. and is it set as the default printer in:-

I’m not trying to print to any printer in particular, as I don’t get the printer dialogue showing up to select a printer, when i click on the print icon within tuxpaint I immediately get an error message saying “sorry! your picture could not be printed” so I don’t get to select a printer.

For some reason i seem to have the Brother printer installed twice (MFC-210C & [email protected]) but the default is MFC-210C

Tuxpaint doesn’t open the print dialog … it just prints to the “default” printer ith no dialog at all.

So is the MFC printer the default printer ?

is cups-bsd installed

is the printer switched on ?

Tuxpaint doesn't open the print dialog .. it just prints to the "default" printer ith no dialog at all.

Sorry I didn’t know that

is cups-bsd installed

Yes I installed it from synaptic

is the printer switched on ?

Yes and I can print to it from the PC in other applications ie gedit and from the internet

Is the MFC the “default” printer ?

Is the MFC the "default" printer ?

Yes

Sorry i forgot to answer that on your last post :slight_smile:

gedit ~/.tuxpaintrc

add a single line that reads

printcommand=lpr -P Brother-MFC-210C

SAVE the file.

If open, close tuxpaint … and reopen it.

Now what happens if you try to print ?

Now what happens if you try to print ?

It’s just the same 'm afraid :frowning:

Ok forget that last post, it’s working

after i first edited the file as you instructed and saved it it was just the same, then I went into the tuxpaint config tool and clicked use “all users” settings, then I checked the tuxpaintrc and it was completely wiped, so I followed your instructions again and now it’s working :slight_smile:

I still have the cups problem, maybe can we work on that tomorrow or some other time thats suitable ?

Anyway once again thanks for your help, I’m in your debt again

Many thanks

Graeme

No problem … we’ll see if we can get to the bottom of the CUPS issue another day :slight_smile: