reverting back to php version 5.2 from 5.3

Hi Guys,

Currently in need of rolling back my PHP version as an app i wish to use is known to have isasues with it.

currently using Ubunutu 11.10
I have Webmin installed
Apache
i did read breifly some where that you could run two versions of PHP but could do with some help on the steps i need to take for either option.

Any help is appreciated as always guys.

Cheers Makin

Currently in need of rolling back my PHP version as an app i wish to use is known to have isasues with it.
It might be for different versions but you could try to adopt this solution

Thanks Sezo,

Wonders if any one can confirm if this would work on my linux version.

also I guess from reading the script i have some concerns over it removing other files.

listend below is the php files i run on my system.

libapache2-mod-php5 5.3.6-13ubuntu3.10
php5 5.3.6-13ubuntu3.10
php5-cli 5.3.6-13ubuntu3.10
php5-common 5.3.6-13ubuntu3.10
php5-curl 5.3.6-13ubuntu3.10
php5-gd 5.3.6-13ubuntu3.10
php5-mcrypt 5.3.5-0ubuntu1
php5-mysql 5.3.6-13ubuntu3.10
php5-xmlrpc 5.3.6-13ubuntu3.10
phpmyadmin 3.4.5-1

Am i right in thinking that the script would indeed remove all of these.

Yes, this part of the script would list all PHP files

with dpkg -l| grep php
PHPLIST=$(for i in $(dpkg -l | grep php|awk ‘{ print $2 }’ ); do echo $i; done)

So to see in advance which files would be removed you could use this:

dpkg -l | grep php

Thanks again for the quick response.

After running the command as suggested it brought up the following:

dpkg -l | grep php
ii libapache2-mod-php5 5.3.6-13ubuntu3.10 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.3.6-13ubuntu3.10 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.3.6-13ubuntu3.10 command-line interpreter for the php5 scripting language
ii php5-common 5.3.6-13ubuntu3.10 Common files for packages built from the php5 source
ii php5-curl 5.3.6-13ubuntu3.10 CURL module for php5
ii php5-gd 5.3.6-13ubuntu3.10 GD module for php5
ii php5-mcrypt 5.3.5-0ubuntu1 MCrypt module for php5
ii php5-mysql 5.3.6-13ubuntu3.10 MySQL module for php5
ii php5-xmlrpc 5.3.6-13ubuntu3.10 XML-RPC module for php5
ii phpmyadmin 4:3.4.5-1 MySQL web administration tool

My concerns are will this impact any of my MYQL databases that are currently live and running for other applications?

My concerns are will this impact any of my MYQL databases that are currently live and running for other applications?

Looking at that returned list of packages to be removed, I can only see:

ii php5-mysql 5.3.6-13ubuntu3.10 MySQL module for php5 ii phpmyadmin 4:3.4.5-1 MySQL web administration tool

Neither seems to be critical to MYSQL unless the database applications are running through PHP.

In that case the usual advice would be is to do a complete backup of your system

The script rolled back to php 5.2 successfully.

Thankyou for the support in regards to this.