[SOLVED] Want (or rather NEED to) install Window$ help diag problem... Need help

I am having speed problems with my broadband and VM will not help any further as I am not running Window$, so I am having to see if I can install my copy of XP in place of where I have installed one of my Ubuntu or variants.
All my HD’s are formatted to EXT4 so I know I’m going to have to format a partition to NTFS to install XP.
Is it as easy as installing Ubuntu to a partition or is there more involved?

No, it is not as easy as that. Remeber according to Windows there IS no other operating system out there.
I would suggest (if you have a spare HDD) to remove ALL disks that contain other operating systems and leave in place the one you can dedicate to XP.
There should be no partitions on this drive prior to install. In other words, you dedicate the HDD and machine to XP.

I’m sure I can manage that. I have Kubuntu 14.04 on sda and I’ve given up using it as it seems rather unstable as it keeps crashing.
Do I just install as normal on sda (I know in window$ its called something else). Is there anything I need to do about the grub after installing XP?

I’ve done a search (which was a rare find) to install Window$ SECOND and have Ubuntu as a first install instead of the usual Window$.
http://apcmag.com/how_to_dual_boot_linux_and_windows_xp_linux_installed_first.htm#null

I have got my XP Install disc and decided to wipe sda and put XP on it, BUT…

When booting and selecting to install XP on sda it will not install it either when the HD is formatted to NTFS or wiped and unformatted. am I doing something wrong???

When trying to install XP, I am informed that XP is unable to be installed due to the HD not being NTFS and given the option to go back and format it but when I do that, it still comes up with ‘unable to install’ because of the HD’s format.

[EDIT]
I am using GParted in Ubuntu 14.04 to format sda.

If you are installing XP on to the first drive (/dev/sda) then from gparted delete all partitions so it is all free space, then go Device->Create Partition Table->MSDOS and stop there.
Then use the XP install disk to create the partitions during install.

I’ve tried that, I wipe the HD so it shows ‘unallocated’ then highlight the drive again then select ‘Device’ then select ‘Create Partition Table’.
Then reboot to install XP but it still comes up with ‘Unable to install’

If you delete the partition table and don’t create a new one (i.e. leave as unallocated), does XP install then?

Not that I can recall.
I have tried many different variations but will have a last attempt at setting partition table and file system at unallocated and then set to msdos and unallocated.
I don’t want to hear that the HD is dead :wink: as it was booting perfectly fine with Kubuntu 14.04.

Just had a look at what I can set the partition table to and there is no setting to set it to nothing, only;
msdos
aix
amiga
bsd
dvh
gpt
mac
pc98
sun
loop

You don’t HAVE to set it, just delete the partition table and leave it at that

Tried it and it is still failing to install, saying it’s not a valid XP partition or something, even after the installation disk partitions it.

You could try to follow the instructions from here and see if you get anywhere.

Could the drive still have a corrupt partition table with an invalid GPT signature.

See here:
http://askubuntu.com/questions/287352/ubuntu-13-04-installation-does-not-detect-windows-7

Tried that Mark but it’s still failing to install as its coming up with ‘not a valid XP partition’

You’re either going to have to use Gparted to creeate a single large NTFS partition on the drive.

or

use the fdisk command from the XP recovery console to create a windows partition.
(yes Windows has an fdisk command too)

I’ll try first with part partitioning the Hd but as it’s failing to do that itself with the install disk, I’m not 100% sure it’ll work.
But we won’t know unless we try eh!

That failed, still comes up with not an XP partition.
So… How do I use the fdisk to create it from within the install disk?

When you get to the partitioning part of the XP install (blue screen yellow writing) as pictured here:
http://superuser.com/questions/55929/how-to-solve-disk-does-not-contain-a-windows-xp-compatible-partition-during-in
Use the down arrow to selecdt a partition and hit D to delete it … until you have non left.

Then hit C and create a single partition using the whole disk, and tell XP to format it as NTFS.

[EDIT]

Damn … got sucked into providing Windows support on a Linux forum again ::slight_smile:

That won’t/didn’t work (tried it many times before). So…
I’ve figured on a workaround… I’ve installed Virtualbox and installed XP in there.
I only need it to please VM as they wont give me any tech support if I’m not running Window$
They want me to run through some settings to check my end as they say there’s nothing wrong with anything their end ???